Posts from 2016-02

cisco: ASA 5510 basic setup

posted on 2016-02-29 22:49:46

This is almost the same posting as the previous one on setting up the 5505, but with some adjustments.

To have a very basic and usable ASA device after a factory reset, you might consider the commands presented in the following. These were entered into the device via a serial connection to the console port.

Usually this connection's speed is 9600 baud 8N1, in case you wonder.

ASDM will be available in LAN, not just via the Management port. Further there private IP networks being used for ingress and egress networks.

first aid

  • Use TAB to expand all the mentioned commands.
  • Use ? to show available commands.
  • In (config), use sh run to show your current configuration.

In case you need more in depth info, here is the original page from cisco.

modes

There are several modes, in very short:

  • EXEC = only most basic commands ('>' prompt)
  • privileged EXEC = you can now reboot and possibly change config ('#' prompt, enter via ena)
  • config = you can change configuration ('(config)' prompt, enter via conf t)

first steps upon fresh connect after a factory reset

! ! denotes comments and do not need being entered

! privileged mode
ena
! hit enter, initially no password needed

! now enter configure mode
conf t

! which box are we working on?
ho <hostname>

! set enable password
! can be used later for ASDM, too, which username being omitted
ena p <password>

set external and interal networks onto physical port

! maybe instead of 'E' you need 'G' for gigabit interfaces
in E 0/0
no shut
sec 0
ip ad 10.0.0.1 255.255.255.0
nameif OUTSIDE

in E 0/1
no shut
sec 100
ip ad 192.168.0.1 255.255.255.0
nameif INSIDE

! management IF, in case you want it
!in M 0/0

!exit
q

ASDM

! enable asdm...
ht s en

! ... from LAN
ht 192.168.0.0 255.255.255.0 INSIDE

save and reboot

wr mem
rel

ASA's are painful to maintain.

cisco: ASA 5505 basic setup

posted on 2016-02-29 22:49:46

To have a very basic and usable ASA device after a factory reset, you might consider the commands presented in the following. These were entered into the device via a serial connection to the console port.

Usually this connection's speed is 9600 baud 8N1, in case you wonder.

ASDM will be available in LAN, not just via the Management port. Further there private IP networks being used for ingress and egress networks.

first aid

  • Use TAB to expand all the mentioned commands.
  • Use ? to show available commands.
  • In (config), use sh run to show your current configuration.

modes

There are several modes, in very short:

  • EXEC = only most basic commands ('>' prompt)
  • privileged EXEC = you can now reboot and possibly change config ('#' prompt, enter via ena)
  • config = you can change configuration ('(config)' prompt, enter via conf t)

first steps upon fresh connect after a factory reset

! ! denotes comments and do not need being entered

! privileged mode
ena
! hit enter, initially no password needed

! now enter configure mode
conf t

! which box are we working on?
ho <hostname>

! set enable password
! can be used later for ASDM, too, which username being omitted
ena p <password>

create VLAN for external and interal network

in Vlan1
 nameif OUTSIDE
 sec 1
 ip ad 10.0.0.1 255.255.255.0

in Vlan10
 nameif INSIDE
 sec 100
 ip ad 192.168.1.1 255.255.255.0

! exit
q

set vlans for your physical interfaces

! first your uplink
in E 0/0
 no shut
 sw a v 1

! now the others
in E 0/1
 no shut
 sw a v 10

in E 0/2
 no shut
 sw a v 10

in E 0/3
 no shut
 sw a v 10

! of course you can do it for all others, too, if you want
! else:
q

ASDM

! enable asdm...
ht s en

! ... from LAN
ht 192.168.1.0 255.255.255.0 INSIDE

save and reboot

wr mem
rel

ASA's are painful to maintain.

Servers and Java WebGUI problems

posted on 2016-02-29 16:59:00

Often server and device manufacturers do ship their hardware with java-based administration hardware. Even more often, this stuff does not properly work due to your local java install not being up to date or complete. And if your installation is fine, the access to the server in place is restricted by security policies. (...)

Note: this guide is mostly linux specific. For Windows or OSX the steps may differ, even though Java is the same.

Most general steps for using these particular kinds of software are klicking a link, and getting a .jnlp file donwload offered. Afterwards you have to double klick that file, or maybe your system already knows how to open it. Java should start and lets your application run then.

If not, here are solutions to the most common problems.

no java web start application to start

  • no proper programm for running the java application

If you can donwload the .jnlp file, but cannot open it (even though you know you installed java!), it is simply lacking the proper program. Where your java binary is located, there must also exist a javaws binary ("Java Web Start"), which you need to open these files.

Either your system does not use javaws for starting them, but just download and try from the shell:

javaws <filename>.jnlp

Verify it is installed at all:

javaws -version

(All Java programs only use a single dash for their flags, only god knows why.)

app start prohibited due to security policy problems

In your shell, either one of these should work:

ControlPanel
# or
jcontrol

Then the Java Control Panel should start.

Do ist

Choose the Security tab, and add your site URL to the Exception Site List. Afterwards your app should start upon reopening the .jnlp file.

cisco: boot router from USB

posted on 2016-02-29 14:29:20

A very short walkthrough, persisting the image is inclusive:

  • "The USB Flash Module is a hardware device sold by Cisco Systems ® that provides a secondary Flash capability on Universal Serial Bus (USB) ports." (I cited cisco, from the link at the bottom of this post.)

  • "USB drivers have been added to rommon, starting with version 12.4(13r)." (Also from the cisco link.)

  • filesystem has to FAT16, since FAT32 will NOT work

  • ctrl-break (or other) to enter rommon mode

    rommon 1>? rommon 2> dir usbflash0: rommon 3> boot usbflash0: c2800nm-ipbase-mz.124-3.bin

    Router> enable Router # copy usbflash0: c2800nm-ipbase-mz.124-3.bin flash: c2800nm-ipbase-mz.124-3.bin

Here is additional information directly from Cisco.

cisco ASA: ipsec example

posted on 2016-02-28 14:33:03

I fear I will need something like that soon, so here's a dump I found on google somewhere else: (None of the following is from me! But from here)

Table 1 Preconfiguration Checklist: ISAKMP/Phase-1 Attributes

Attribute   Value
Encryption  AES 128-bit
Hashing SHA-1
Authentication method   Preshared keys
DH group    Group 2 1024-bit field
Lifetime    86,400 seconds

We will use main mode rather than aggressive mode for negotiation. IPsec Phase 2 attributes are used to encrypt and decrypt the actual data traffic.

Table 2 Preconfiguration Checklist: IPsec/Phase-2 Attributes

Attribute   Value
Encryption  AES 128-bit
Hashing SHA-1
Lifetime    28,800 seconds4,608,000 kB
Mode    Tunnel
PFS group   None

Now that we have determined what Phase 1 and Phase 2 attributes to use, we’re ready to configure IPsec. We assume that all IP addresses are already configured and basic connectivity exists between Cisco ASA and pfSense firewall.

ASA Configuration

! IPsec ISAKMP Phase 1

crypto ikev1 policy 1
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
exit
!
crypto ikev1 enable outside

tunnel-group 173.199.183.2 type ipsec-l2l
tunnel-group 173.199.183.2 ipsec-attributes
ikev1 pre-shared-key Cisc0

! IPsec Phase 2

crypto ipsec ikev1 transform-set pfSense-AES128SHA esp-aes esp-sha-hmac
!
access-list outside_cryptomap_10 remark ACL to encrypt traffic from ASA to pfSense
access-list outside_cryptomap_10 extended permit ip 192.168.1.0 255.255.255.0 10.0.0.0 255.255.255.0
!
crypto map outside_map 10 match address outside_cryptomap_10
crypto map outside_map 10 set peer 173.199.183.2
crypto map outside_map 10 set ikev1 transform-set pfSense-AES128SHA
crypto map outside_map interface outside

openssl: check privkey, cert request, certificate

posted on 2016-02-26 13:50:50

Here is a one-liner that prompts you to enter the filenames of your private key, your certificate's request and your final certificate:

echo; echo $'\e[32;1m'"cd into keyfolder, enter filenames when prompted."$'\e[0m'; ls -lah; echo; read -p "privkey:  " fn; read -p "certreq:  " csr; read -p "certname: " cert; openssl rsa -in $fn -modulus -noout | openssl md5; openssl req -in $csr -modulus -noout | openssl md5; openssl x509 -in  $cert -modulus -noout | openssl md5'

Only if all hash value results are the same, your files will work. If they differ something is broken and you have to have a more in-depth look.

Shopware: temp domain

posted on 2016-02-26 09:59:32

When migrating a shopware installation or creating a testing environment, the shop has to run under a different URL.

As of version 5.1.3 this is done like this: (Most of this is self explanatory, but still...)

  • Set up the virtual host in your webserver.
  • Make sure you have your dns entries set up accordingly.
  • Change the .htaccess, so the rewrite rule will lead to your temporal domain.
  • Change two fields in the shops database, where the URL is set, too.

On the last two points, heres some more info how things should look like for my example WWW.MYDOMAIN.DE.

.htaccess:

RewriteCond %{HTTP_HOST} ^MYDOMAIN.DE [NC]
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://WWW.MYDOMAIN.DE/$1 [R,L]

Database: (see lines 8 host and 11 hosts, 5 name should not matter )

 1  mysql> SELECT * FROM s_core_shops\G
 2  *************************** 1. row ***************************
 3                    id: 1
 4               main_id: NULL
 5                  name: WWW.MYDOMAIN.DE
 6                 title: NULL
 7              position: 1
 8                  host: WWW.MYDOMAIN.DE
 9             base_path: NULL
10              base_url: NULL
11                 hosts: WWW.MYDOMAIN.DE
12                secure: 1
13           secure_host: NULL
14      secure_base_path: NULL
15           template_id: 33
16  document_template_id: 22
17           category_id: 3
18             locale_id: 1
19           currency_id: 1
20     customer_group_id: 1
21           fallback_id: NULL
22        customer_scope: 0
23               default: 1
24                active: 1
25         always_secure: 1
26  *************************** 2. row ***************************

...

Basically, you have to change the fields host and hosts in the s_core_shops table to your temp domain URL.

Shopware: Plugin install problems

posted on 2016-02-26 09:41:42

When trying to install a Plugin into Shopware via its plugin manager in the backend, the plugin would not install at all.

After some discerning, the solution was to redownload shopware from the downloadpage here and to remove and reupload the vendor folder on the webserver. (Remember to set the permissions accordingly, if you use scp.)

Afterwards all should be fine, even though stuff will not work immeadiatly. Clearing the cache, logout of the backend and login in again, and the plugin should be installable / present then.

firewall: block DHCP traffic

posted on 2016-02-20 23:29:26

To block DHCP reqests as well as responses, block:

src port range 67 to 68
dst port range 67 to 68

Why?

[ jl@jl ~ ] 23:31:06 $ \grep -e '\s67/' -e '\s68/' /etc/services 
bootps          67/tcp                          # BOOTP server
bootps          67/udp
bootpc          68/tcp          dhcpc           # BOOTP client
bootpc          68/udp          dhcpc

Which means port 67->68 are DHCP responses, whereas 68->67 are DHCP requests.

apache: set multiple origin domains

posted on 2016-02-19 13:14:51

Exchange your domain with MYDOMAIN\.DE and WWW\.MYDOMAIN\.DE:

SetEnvIf Origin "^http(s)?://(.+\.)?(MYDOMAIN\.DE|WWW\.MYDOMAIN\.DE)$" origin_is=$0 
Header always set Access-Control-Allow-Origin %{origin_is}e env=origin_is

Put these lines in a config of your choice, likely in /etc/apache2/include.d/<filename>.conf.

typo3: password reset

posted on 2016-02-18 10:05:04

admin password for the backend through mysql

UPDATE be_users SET password=md5('your_new_password') WHERE username = 'admin';

reset install tool password

In [your_site]/typo3conf/LocalConfiguration.php do:

$TYPO3_CONF_VARS['BE']['installToolPassword'] = 'bacb98acf97e0b6112b1d1b650b84971';

This will give you the default password of joh316 again.

This stuff comes from the manual here.

openvpn: dns pushed on linux

posted on 2016-02-14 22:45:53

To have openvpn push its DNS server successfully through the tunnel, you have to have these settings in your <filename>.ovpn file:

script-security 2
up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf

and have the package resolvconf installed:

apt install resolvconf

That way your dns servers get exhanged in /etc/resolv.conf everytime the tunnel get established or disconnected.

This was only tested on debian.

proxmox: unable to open database

posted on 2016-02-12 00:29:25

problem

After a reboot a promox hypervisor did not come back up properly...

While this may sound like quite a dumb story, it can actually be fun if you like figuring out things. Except that you maybe don't. And the system where this broke was of course a production system where the customer is waiting for you to fix things.

Anyway: You do not really need to reinstall in case you read something like this:

Restarting pve cluster filesystem: pve-cluster[database] crit: found entry with duplicate name (inode = 0000000000000160, parent = 00000000000000F2, name = 'qemu-server')
[database] crit: DB load failed
[main] crit: memdb_open failed - unable to open database '/var/lib/pve-cluster/config.db'
[main] notice: exit proxmox configuration filesystem (-1)
 (warning).

Promox stores the configuration of /etc/pve in a sqlite database: /var/lib/pve-cluster/config.db.

reason

So when this happens, there is simply a duplicate entry, which you can fix with regular sqlite foo. Due to the duplicate entry proxmox cannot read the sqlite database, and so i will not know how to create the folders and files to populate /etc/pve, as the whole information about all these folders and files in this directory node is saved within sqlite.

See the example below, dont be fooled, the data column is just shown too small. Either use .mode line or look up the size via .show to change .width of the column so you can read the file content, but nevermind for now.

Usually you change the contents of /etc/pve while it is mounted, the state will be written the the database to. (I have no idea either, but nonetheless cannot be bothered to look this up in the promox sources.)

Without a clean databse, it can't mount /etc/pve, and neither can you fix it by copying files. (...)

solution

Open the database, delete one entry if both are duplicate (But save the data in a texteditor in case you should need it later.) of fix it somehow.

It's easy:

sqlite3 /var/lib/pve-cluster/config.db

sqlite> .databases
seq  name             file                                                      
---  ---------------  ----------------------------------------------------------
0    main             /var/lib/pve-cluster/config.db                            
sqlite> .tables
tree
sqlite> 

You see, there's only a single database in there (to be honest, I do not know if sqlite can handle more.) called main with a single table called tree. There you can simply use UPDATE or DELETE statements from sql.

sqlite> .headers on
sqlite> select * from tree;

inode       parent      version     writer      mtime       type        name         data      
----------  ----------  ----------  ----------  ----------  ----------  -----------  ----------
0           0           371         0           1455194525  8           __version__            
2           0           3           0           1410521743  8           user.cfg     user:root@
4           0           5           0           1410521743  8           datacenter.  keyboard: 
6           0           6           0           1410521891  4           priv                   
8           0           8           0           1410521891  4           nodes                  
9           8           9           0           1410521891  4           my_server              
10          9           10          0           1410521891  4           qemu-server            
11          9           11          0           1410521891  4           openvz                 
12          9           12          0           1410521891  4           priv                   
13          6           14          0           1410521892  8           authkey.key  -----BEGIN
15          0           16          0           1410521892  8           authkey.pub  -----BEGIN
17          0           18          0           1410521892  8           pve-www.key  -----BEGIN
19          9           20          0           1410521892  8           pve-ssl.key  -----BEGIN
21          6           22          0           1410521892  8           pve-root-ca  -----BEGIN
23          0           24          0           1410521892  8           pve-root-ca  -----BEGIN
25          6           232         0           1455173387  8           pve-root-ca  03
28          9           31          0           1410521892  8           pve-ssl.pem  -----BEGIN
39          0           41          0           1410521892  8           vzdump.cron  # cluster 
137         6           137         0           1410903436  4           lock                   
224         8           224         0           1455173387  4           my_server_0            
225         224         225         0           1455173387  4           qemu-server            
225         224         225         0           1455173387  4           qemu-server            
226         224         226         0           1455173387  4           openvz                 
227         224         227         0           1455173387  4           priv                   
228         224         229         0           1455173387  8           pve-ssl.key  -----BEGIN
230         224         233         0           1455173387  8           pve-ssl.pem  -----BEGIN
260         225         261         0           1455173556  8           101.conf     bootdisk: 
360         6           368         0           1455194525  8           authorized_  # This fil
369         6           371         0           1455194525  8           known_hosts  |1|Z2FUpc+

sqlite> .mode insert
sqlite> select * from tree;

... in the rather longish output now search for the corresponding double line:

INSERT INTO table VALUES(225,224,225,0,1455173387,4,'qemu-server',NULL);

Then delete the double line and reinsert it, so it only appears once.

sqlite> delete from tree where inode=225;

Now, to reinsert, replace table with tree:

sqlite> INSERT INTO tree VALUES(225,224,225,0,1455173387,4,'qemu-server',NULL);

Of course, the described aproach only works if you have duplicate entries. If there is something else borked, you have to fix this, and not just delete an entry from the database.

But if you happen to know what you are doing, this should not pose a problem. After proxmox can read the database again, you can change its contents again by editing the mounted data at /etc/pve, which will be saved when you quit or so. (I don't know the exact time when this happens.)

Linux: show samba shares

posted on 2016-02-11 18:48:04

To easily show available samba shares, try this:

[ sjas@nb ~ ] 18:45:26 $ smbclient -L 10.0.0.100
Enter sjas's password:
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 4.1.17-Debian]

    Sharename       Type      Comment
    ---------       ----      -------
    print$          Disk      Printer Drivers
    Folder1  Disk
    Folder2  Disk
    Folder3  Disk
    Folder1IPC$            IPC       IPC Service (Samba 4.1.17-Debian)
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 4.1.17-Debian]

    Server               Comment
    ---------            -------
    VS10356              Samba 4.1.17-Debian

    Workgroup            Master
    ---------            -------
    WORKGROUP            samba-hostname

I used an arbitrary password, still worked.

SSL certificate check from shell

posted on 2016-02-05 12:53:33

This will show the complete certificate:

echo | openssl s_client -connect google.com:443 2>/dev/null | openssl x509 -noout -text

Exchange the -text flag with any other object which are present in the certificate to get different results. (I.e. -subject or -dates.)

Magento: find out version from shell

posted on 2016-02-03 13:37:57

From within the docroot of your installation:

find . -iname Mage.php | xargs grep "public static function getVersionInfo" -A10

This should do until the code gets changed, tested with the 1.9.0.1 release.

Magento: Security check / patch status

posted on 2016-02-03 13:14:44

To check if your magento installation is up to date, try using this. Missing patches can be found here.

Linux: /proc overview

posted on 2016-02-02 05:32:55

This should do rather nicely:

for i in $(ls -l /proc/ | grep -e '^-' | awk '{print $9}' | grep -v -ekcore -ekallsyms -ekmsg -ekpagecount -ekpageflags); do echo $'\e[33;1m'$i$'\e[0m'; cat /proc/$i; done | less -R

All files from /proc/* are shown, except the memory maps (which won't help for browsing /proc anyway.).

Should you want to know which files/folders do exist besides the ones in /proc/*, try this:

for i in $(ls -l /proc | grep "^d" | awk '{print $9}' | grep -v -e "^[[:digit:]]"); do echo $'\e[33;1m'$i$'\e[0m'; find /proc/$i; done | less -R

It's nice to see improve, after all I dimly remember doing this in the past here, but this solution now is way better and also less brittle than that.

Besides, man 5 proc might help a little, too.

This blog covers .csv, .htaccess, .pfx, .vmx, /etc/crypttab, /etc/network/interfaces, /etc/sudoers, /proc, 10.04, 14.04, AS, ASA, ControlPanel, DS1054Z, GPT, HWR, Hyper-V, IPSEC, KVM, LSI, LVM, LXC, MBR, MTU, MegaCli, PHP, PKI, R, RAID, S.M.A.R.T., SNMP, SSD, SSL, TLS, TRIM, VEEAM, VMware, VServer, VirtualBox, Virtuozzo, XenServer, acpi, adaptec, algorithm, ansible, apache, apachebench, apple, applet, arcconf, arch, architecture, areca, arping, asa, asdm, autoconf, awk, backup, bandit, bar, bash, benchmarking, binding, bitrate, blackarmor, blockdev, blowfish, bochs, bond, bonding, booknotes, bootable, bsd, btrfs, buffer, c-states, cache, caching, ccl, centos, certificate, certtool, cgdisk, cheatsheet, chrome, chroot, cisco, clamav, cli, clp, clush, cluster, coleslaw, colorscheme, common lisp, configuration management, console, container, containers, controller, cron, cryptsetup, csync2, cu, cups, cygwin, d-states, database, date, db2, dcfldd, dcim, dd, debian, debug, debugger, debugging, decimal, desktop, df, dhclient, dhcp, diff, dig, display manager, dm-crypt, dmesg, dmidecode, dns, docker, dos, drivers, dtrace, dtrace4linux, du, dynamictracing, e2fsck, eBPF, ebook, efi, egrep, emacs, encoding, env, error, ess, esx, esxcli, esxi, ethtool, evil, expect, exportfs, factory reset, factory_reset, factoryreset, fail2ban, fbsd, fdisk, fedora, file, filesystem, find, fio, firewall, firmware, fish, flashrom, forensics, free, freebsd, freedos, fritzbox, fsck, fstrim, ftp, ftps, g-states, gentoo, ghostscript, git, git-filter-branch, github, gitolite, global, gnutls, gradle, grep, grml, grub, grub2, guacamole, hardware, haskell, hdd, hdparm, hellowor, hex, hexdump, history, howto, htop, htpasswd, http, httpd, https, i3, icmp, ifenslave, iftop, iis, imagemagick, imap, imaps, init, innoDB, innodb, inodes, intel, ioncube, ios, iostat, ip, iperf, iphone, ipmi, ipmitool, iproute2, ipsec, iptables, ipv6, irc, irssi, iw, iwconfig, iwlist, iwlwifi, jailbreak, jails, java, javascript, javaws, js, juniper, junit, kali, kde, kemp, kernel, keyremap, kill, kpartx, krypton, lacp, lamp, languages, ldap, ldapsearch, less, leviathan, liero, lightning, links, linux, linuxin3months, lisp, list, livedisk, lmctfy, loadbalancing, locale, log, logrotate, looback, loopback, losetup, lsblk, lsi, lsof, lsusb, lsyncd, luks, lvextend, lvm, lvm2, lvreduce, lxc, lxde, macbook, macro, magento, mailclient, mailing, mailq, manpages, markdown, mbr, mdadm, megacli, micro sd, microsoft, minicom, mkfs, mktemp, mod_pagespeed, mod_proxy, modbus, modprobe, mount, mouse, movement, mpstat, multitasking, myISAM, mysql, mysql 5.7, mysql workbench, mysqlcheck, mysqldump, nagios, nas, nat, nc, netfilter, networking, nfs, nginx, nmap, nocaps, nodejs, numberingsystem, numbers, od, onyx, opcode-cache, openVZ, openlierox, openssl, openvpn, openvswitch, openwrt, oracle linux, org-mode, os, oscilloscope, overview, parallel, parameter expansion, parted, partitioning, passwd, patch, pct, pdf, performance, pfsense, php, php7, phpmyadmin, pi, pidgin, pidstat, pins, pkill, plasma, plesk, plugin, posix, postfix, postfixadmin, postgres, postgresql, poudriere, powershell, preview, profiling, prompt, proxmox, ps, puppet, pv, pveam, pvecm, pvesm, pvresize, python, qemu, qemu-img, qm, qmrestore, quicklisp, quickshare, r, racktables, raid, raspberry pi, raspberrypi, raspbian, rbpi, rdp, redhat, redirect, registry, requirements, resize2fs, rewrite, rewrites, rhel, rigol, roccat, routing, rs0485, rs232, rsync, s-states, s_client, samba, sar, sata, sbcl, scite, scp, screen, scripting, seafile, seagate, security, sed, serial, serial port, setup, sftp, sg300, shell, shopware, shortcuts, showmount, signals, slattach, slip, slow-query-log, smbclient, snmpget, snmpwalk, software RAID, software raid, softwareraid, sophos, spacemacs, spam, specification, speedport, spi, sqlite, squid, ssd, ssh, ssh-add, sshd, ssl, stats, storage, strace, stronswan, su, submodules, subzone, sudo, sudoers, sup, swaks, swap, switch, switching, synaptics, synergy, sysfs, systemd, systemtap, tar, tcpdump, tcsh, tee, telnet, terminal, terminator, testdisk, testing, throughput, tmux, todo, tomcat, top, tput, trafficshaping, ttl, tuning, tunnel, tunneling, typo3, uboot, ubuntu, ubuntu 16.04, udev, uefi, ulimit, uname, unetbootin, unit testing, upstart, uptime, usb, usbstick, utf8, utm, utm 220, ux305, vcs, vgchange, vim, vimdiff, virtualbox, virtualization, visual studio code, vlan, vmstat, vmware, vnc, vncviewer, voltage, vpn, vsphere, vzdump, w, w701, wakeonlan, wargames, web, webdav, weechat, wget, whois, wicd, wifi, windowmanager, windows, wine, wireshark, wpa, wpa_passphrase, wpa_supplicant, x11vnc, x2x, xfce, xfreerdp, xmodem, xterm, xxd, yum, zones, zsh


Unless otherwise credited all material Creative Commons License by sjas